PHP libcurl 升级

今天解决一个微信退款 “certificate not match” 的问题。这个错误是说:微信证书错误。开始以为是证书路径问题,经过排查发现并非路径问题,而是libcurl 版本的问题,可能是微信服务器升级了libcurl吧,他们要求libcurl 必须使用 7.20以上版本。所以只能升级服务器…..

下面说一下我的步骤吧:

首先下载安装包:https://curl.haxx.se/download/curl-7.50.3.tar.gz

— 解压到当前目录
# tar -zxf curl-7.50.3.tar.gz
— 进入解压后的目录内
# cd curl-7.50.3
— 配置(如之前安装有指定目录这里也请指定到原来安装的目录,这里是默认安装)
# ./configure
— 编译
# make
— 安装
# make install
— 安装完毕

然后重启PHP即可

CentOS 下 LNMP 环境搭建

今天写一篇关于CentOS 下配置 LNMP 环境的文章。首先我们了解一下什么事LNMP,L表示Linux系统,也就是机器的操作系统;N表示web服务器的一种Nginx;  M这个就简单了表示MySQL,这个做PHP的人应该都知道; 剩下的P 这个毫无疑问就是PHP。名词解释这个其实能看到这篇文章的人本都不用解释,但是为了一些想要了解的人,我还是写了。接着要做的就是LNMP环境的搭建了。不多说直接开始。

首先,我们拿到一台装有CentOS系统的机器,首先需要查看一下机器的配置。

1. 查看硬盘信息   `df -h` 通过这个命令我们可以获取到当前机器已挂载的硬盘信息。

2. 查看系统版本 `uname -a` ,`cat /etc/issue` 这两个命令就可以当前使用系统的版本。

3. 查看当前机器的CPU信息  `cat /proc/cpuinfo` 通过这个命令查看CPU信息。

4. 查看当前机器内存大小  `free -g` 通过这个命令查看内存大小。

接着,更新安装一些必要的扩展依赖。查看完上面的信息我们知道了现在所使用的机器的一些信息之后我们就可以开始安装我们的服务器环境了。

1. 安装必要的扩展依赖

yum安装扩展
wget patch make cmake gcc gcc-c++ gcc-g77 flex bison file libtool libtool-libs autoconf kernel-devel libjpeg libjpeg-devel libpng libpng-devel libpng10 libpng10-devel gd gd-devel freetype freetype-devel libxml2 libxml2-devel zlib zlib-devel glib2 glib2-devel bzip2 bzip2-devel libevent libevent-devel ncurses ncurses-devel curl curl-devel e2fsprogs e2fsprogs-devel krb5 krb5-devel libidn libidn-devel openssl openssl-devel vim-minimal nano fonts-chinese gettext gettext-devel gmp-devel pspell-devel unzip libcap autoconf

继续阅读CentOS 下 LNMP 环境搭建

免费的编程中文书籍索引 – 分享

迷渡:免费的编程中文书籍索引 – 分享

本文之前发布过,近半年后,本文作者(迷渡,JustJavaC)大幅度进行了更新,因此再次分享给大家。感谢 @justjavac 和众多的分享者!感谢写作这些文档、手册的人们!

语言无关类

操作系统

智能系统

继续阅读免费的编程中文书籍索引 – 分享

Linux下PHP扩展编译安装

在我们实际开发中,经常会出现需要使用一些新的扩展。但是之前的扩展是我们在安装PHP的时候就已经把他们编译进php一块儿安装好了,那么这些扩展我们是不是还要重新编译,然后重编php安装呢?!其实大家都知道答案是不用,但是我们怎么把这些扩展编进php去呢?!其实很简单了,废话不多说了,进正题。

首先下载要安装的扩展包。

接着解压扩展安装包。

继续阅读Linux下PHP扩展编译安装